pipdeptree

From wikieduonline
Jump to navigation Jump to search

wikipedia:pipdeptree

pip3 install pipdeptree
pipdeptree --help

Example[edit]

aiohttp==3.8.1
 - aiosignal [required: >=1.1.2, installed: 1.2.0]
   - frozenlist [required: >=1.1.0, installed: 1.3.0]
 - async-timeout [required: >=4.0.0a3,<5.0, installed: 4.0.2]
 - attrs [required: >=17.3.0, installed: 21.4.0]
 - charset-normalizer [required: >=2.0,<3.0, installed: 2.0.12]
 - frozenlist [required: >=1.1.1, installed: 1.3.0]
 - multidict [required: >=4.5,<7.0, installed: 6.0.2]
 - yarl [required: >=1.0,<2.0, installed: 1.7.2]
   - idna [required: >=2.0, installed: 3.3]
   - multidict [required: >=4.0, installed: 6.0.2]
gsutil==5.10
 - argcomplete [required: >=1.9.4, installed: 2.0.0]
 - crcmod [required: >=1.7, installed: 1.7]
 - fasteners [required: >=0.14.1, installed: 0.17.3]
 - gcs-oauth2-boto-plugin [required: >=3.0, installed: 3.0]
   - boto [required: >=2.29.1, installed: 2.49.0]
   - google-reauth [required: >=0.1.0, installed: 0.1.1]
     - pyu2f [required: Any, installed: 0.1.5]
       - six [required: Any, installed: 1.16.0]
   - httplib2 [required: >=0.18, installed: 0.20.4]
     - pyparsing [required: >=2.4.2,<4,!=3.0.3,!=3.0.2,!=3.0.1,!=3.0.0, installed: 3.0.9]
   - oauth2client [required: >=2.2.0, installed: 4.1.3]
     - httplib2 [required: >=0.9.1, installed: 0.20.4]
       - pyparsing [required: >=2.4.2,<4,!=3.0.3,!=3.0.2,!=3.0.1,!=3.0.0, installed: 3.0.9]
     - pyasn1 [required: >=0.1.7, installed: 0.4.8]
     - pyasn1-modules [required: >=0.0.5, installed: 0.2.8]
       - pyasn1 [required: >=0.4.6,<0.5.0, installed: 0.4.8]
     - rsa [required: >=3.1.4, installed: 4.7.2]
       - pyasn1 [required: >=0.1.3, installed: 0.4.8]
     - six [required: >=1.6.1, installed: 1.16.0]
   - pyOpenSSL [required: >=0.13, installed: 22.0.0]
     - cryptography [required: >=35.0, installed: 37.0.2]
       - cffi [required: >=1.12, installed: 1.15.0]
         - pycparser [required: Any, installed: 2.21]
   - retry-decorator [required: >=1.0.0, installed: 1.1.1]
   - rsa [required: ==4.7.2, installed: 4.7.2]
     - pyasn1 [required: >=0.1.3, installed: 0.4.8]
   - six [required: >=1.12.0, installed: 1.16.0]
 - google-apitools [required: >=0.5.32, installed: 0.5.32]
   - fasteners [required: >=0.14, installed: 0.17.3]
   - httplib2 [required: >=0.8, installed: 0.20.4]
     - pyparsing [required: >=2.4.2,<4,!=3.0.3,!=3.0.2,!=3.0.1,!=3.0.0, installed: 3.0.9]
   - oauth2client [required: >=1.4.12, installed: 4.1.3]
     - httplib2 [required: >=0.9.1, installed: 0.20.4]
       - pyparsing [required: >=2.4.2,<4,!=3.0.3,!=3.0.2,!=3.0.1,!=3.0.0, installed: 3.0.9]
     - pyasn1 [required: >=0.1.7, installed: 0.4.8]
     - pyasn1-modules [required: >=0.0.5, installed: 0.2.8]
       - pyasn1 [required: >=0.4.6,<0.5.0, installed: 0.4.8]
     - rsa [required: >=3.1.4, installed: 4.7.2]
       - pyasn1 [required: >=0.1.3, installed: 0.4.8]
     - six [required: >=1.6.1, installed: 1.16.0]
   - six [required: >=1.12.0, installed: 1.16.0]
 - google-auth [required: >=2.5.0, installed: 2.8.0]
   - cachetools [required: >=2.0.0,<6.0, installed: 5.2.0]
   - pyasn1-modules [required: >=0.2.1, installed: 0.2.8]
     - pyasn1 [required: >=0.4.6,<0.5.0, installed: 0.4.8]
   - rsa [required: >=3.1.4,<5, installed: 4.7.2]
     - pyasn1 [required: >=0.1.3, installed: 0.4.8]
   - six [required: >=1.9.0, installed: 1.16.0]
 - google-reauth [required: >=0.1.0, installed: 0.1.1]
   - pyu2f [required: Any, installed: 0.1.5]
     - six [required: Any, installed: 1.16.0]
 - httplib2 [required: >=0.20.4, installed: 0.20.4]
   - pyparsing [required: >=2.4.2,<4,!=3.0.3,!=3.0.2,!=3.0.1,!=3.0.0, installed: 3.0.9]
 - monotonic [required: >=1.4, installed: 1.6]
 - pyOpenSSL [required: >=0.13, installed: 22.0.0]
   - cryptography [required: >=35.0, installed: 37.0.2]
     - cffi [required: >=1.12, installed: 1.15.0]
       - pycparser [required: Any, installed: 2.21]
 - retry-decorator [required: >=1.0.0, installed: 1.1.1]
 - six [required: >=1.12.0, installed: 1.16.0]
pipdeptree==2.2.1
 - pip [required: >=6.0.0, installed: 22.0.4]
requests==2.28.0
 - certifi [required: >=2017.4.17, installed: 2022.6.15]
 - charset-normalizer [required: ~=2.0.0, installed: 2.0.12]
 - idna [required: >=2.5,<4, installed: 3.3]
 - urllib3 [required: >=1.21.1,<1.27, installed: 1.26.9]
setuptools==60.10.0
virtualenv==20.14.1
 - distlib [required: >=0.3.1,<1, installed: 0.3.4]
 - filelock [required: >=3.2,<4, installed: 3.7.1]
 - platformdirs [required: >=2,<3, installed: 2.5.2]
 - six [required: >=1.9.0,<2, installed: 1.16.0]
wheel==0.37.1

See also[edit]