Difference between revisions of "Certbot renew"

From wikieduonline
Jump to navigation Jump to search
(One intermediate revision by the same user not shown)
Line 8: Line 8:
 
</pre>
 
</pre>
  
 +
 +
== With ERRORS ==
 
<pre>
 
<pre>
 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Line 22: Line 24:
 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
 
</pre>
 
</pre>
 +
 +
 +
Revier your configuration: /etc/letsencrypt/renewal/DOMAIN.com.conf, check for renewl process configuration
 +
 +
.../...
 +
# Options used in the renewal process
 +
[renewalparams]
 +
account = t513041ebec01207237ef7251192397t
 +
pref_challs = dns-01,
 +
authenticator = manual
 +
manual_public_ip_logging_ok = True
 +
 +
or
 +
 +
# Options used in the renewal process
 +
[renewalparams]
 +
account = t513041ebec01207237ef7251192397t
 +
pref_challs = http-01,
 +
authenticator = standalone
 +
server = https://acme-v02.api.letsencrypt.org/directory
 +
 +
  
 
== See also ==
 
== See also ==
 
* {{certbot}}
 
* {{certbot}}
 +
 +
[[Category:Security]]

Revision as of 04:23, 27 March 2020

Saving debug log to /var/log/letsencrypt/letsencrypt.log

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

No renewals were attempted.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -


With ERRORS

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Processing /etc/letsencrypt/renewal/DOMAIN.com.conf
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Cert is due for renewal, auto-renewing...
Could not choose appropriate plugin: The manual plugin is not working; there may be problems with your existing configuration.
The error was: PluginError('An authentication script must be provided with --manual-auth-hook when using the manual plugin non-interactively.',)
Attempting to renew cert (DOMAIN.com) from /etc/letsencrypt/renewal/DOMAIN.com.conf produced an unexpected error: The manual plugin is not working; there may be problems with your existing configuration.
The error was: PluginError('An authentication script must be provided with --manual-auth-hook when using the manual plugin non-interactively.',). Skipping.
The following certs could not be renewed:
  /etc/letsencrypt/live/DOMAIN.com/fullchain.pem (failure)

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -


Revier your configuration: /etc/letsencrypt/renewal/DOMAIN.com.conf, check for renewl process configuration

.../...
# Options used in the renewal process
[renewalparams]
account = t513041ebec01207237ef7251192397t
pref_challs = dns-01,
authenticator = manual
manual_public_ip_logging_ok = True

or

# Options used in the renewal process
[renewalparams]
account = t513041ebec01207237ef7251192397t
pref_challs = http-01,
authenticator = standalone
server = https://acme-v02.api.letsencrypt.org/directory


See also